Ergebnis 1 bis 8 von 8

Thema: SSL Problem

  1. #1
    Benutzer
    Registriert seit
    12.10.2014
    Beiträge
    51
    Downloads
    15
    Uploads
    0

    SSL Problem

    Hallo,
    meine SSL Verbindung funktioniert nicht mehr , keine verriegeltes Schloss-Symbol in Internet Explorer auch bei Chrom, Opera und Mozilla
    im configure.php ist der SSL wie vorher auf True gesetzt nichts wurde geändert.
    was könnte der grund sein ? , vorher hat alles richtig funktioniert , hat das mit .htaccess zu tun ?

  2. #2
    Benutzer
    Registriert seit
    12.10.2014
    Beiträge
    51
    Downloads
    15
    Uploads
    0

    AW: SSL Problem

    Gelöst : ein link im Header-Bereich bzw. index-USERMOD.html war die Ursache , diese habe ich vor paar tage hinzugefügt, sieht so aus : http://meinDomain.de/images/ordner/einBild.png
    diese http: Annulliert die https Verbindung von Anfang an , ich habe bemerkt bei eine Aktualisierung der Webseite dass der (https und das verriegertes-Schloss) nur für bruchteil einer Sekunde zu sehen und verschwindet sofort wieder, nachdem Korrektur von der oben genannte link so : src="/Images/ordner/einBild.png" ist der sichere Verbindung durch https wieder da , das verriegertes-Schloss im URL zu sehen, man sollte also mit absolute URL als link zu einer Datei innerhalb der selben Domain vorsichtig sein.

  3. #3
    Erfahrener Benutzer Avatar von rf-musik
    Registriert seit
    19.06.2015
    Ort
    Schleswig Holstein im hohen Norden
    Beiträge
    580
    Downloads
    262
    Uploads
    0

    AW: SSL Problem

    Hallo surfer,

    danke für den Hinweis, hatte das gleiche problem, hatte auf der startseite eine weiterleitung mit bild in dem link der als http ausgegeben war, nachdem ich den link selbst und das bild auf dem server gespeichert habe, habe ich auch ein grünes schloss
    Sie sind Kreativ? - alles für Scrapbooking, Kartengestalltung, Stempel & Stanzen
    www.stampcorner.de?2

    meine Private Hobby Seite: www.automatengeschichte.de

    Shop Version 3.12.0.2 StyleEdit 3

  4. #4
    Neuer Benutzer
    Registriert seit
    12.06.2014
    Ort
    Norderstedt
    Beiträge
    10
    Downloads
    5
    Uploads
    0

    AW: SSL Problem

    Hallo,
    ich habe ein SSL-Zertifikat aber das https:// ist nur grau hinterlegt und hat auch kein grünes Schloss. Muß ich noch irgend etwas einstellen. Mein Hosting-Anbieter meint ich muss alle Pfade anpassen, stimmt das und was meint er damit? In der configure.php ist der SSL auf True gesetzt.

  5. #5

  6. #6
    Neuer Benutzer
    Registriert seit
    12.06.2014
    Ort
    Norderstedt
    Beiträge
    10
    Downloads
    5
    Uploads
    0

    AW: SSL Problem

    Hallo Klaus,

    vielen Dank für deine Antwort, wir haben jetzt also folgendes gemacht bei:

    http://gridisonline.de

    Die beiden Dateien:

    /html/xxx/yyy/Dateien/admin/includes/configure.php

    /html/xxx/yyy/Dateien/includes/configure.php

    haben wir wie folgt geändert

    Konfiguration für XTCommerce:

    Aktivieren Sie zuerst SSL in Ihrem Confixx-Adminbereich. Dies ist nur möglich, wenn SSL in Ihrem Paket inkl. ist oder Sie ein eigenes Zertifikat bei uns erworben haben!

    Navigieren Sie dann mit Ihrem FTP-Client in den Installationsordner des Shops. Dort befindet sich der Ordner /includes mit der php-Datei configure.php. Passen Sie die Datei folgendermaßen an:

    Suchen Sie nach den Zeilen:

    define('HTTP_SERVER', 'http://IhreDomain.xy'); // eg, http://localhost - should not be empty for productive servers
    define('HTTPS_SERVER', 'https://IhreDomainxy'); // eg, https://localhost - should not be empty for productive servers
    define('ENABLE_SSL', false); // secure webserver for checkout procedure?

    und ersetzen Sie diese bitte mit:

    define('HTTP_SERVER', 'https://IhreDomain.xy/'); // eg, http://localhost - should not be empty for productive servers
    define('HTTPS_SERVER', 'https://IhreDomainxy/'); // eg, https://localhost - should not be empty for productive servers
    define('ENABLE_SSL', true); // secure webserver for checkout procedure?

    Gehen Sie nun wieder in den Installationsordner des Shops. Dort befindet sich der Ordner /admin/includes wieder mit der php-Datei configure.php. Diese ist ebenfalls anzupassen.

    Suchen Sie dort diese Zeilen:

    define('HTTP_SERVER', 'http://IhreDomain.xy'); // eg, http://localhost - should not be empty for productive servers
    define('HTTP_CATALOG_SERVER', 'http://IhreDomain.xy');
    define('HTTPS_CATALOG_SERVER', '');
    define('ENABLE_SSL_CATALOG', 'false'); // secure webserver for catalog module

    ersetzen Sie diese bitte mit:

    define('HTTP_SERVER', 'https://IhreDomain.xy/'); // eg, http://localhost - should not be empty for productive servers
    define('HTTP_CATALOG_SERVER', 'https://IhreDomain.xy/');
    define('HTTPS_CATALOG_SERVER', 'https://IhreDomain.xy/');
    define('ENABLE_SSL_CATALOG', 'true'); // secure webserver for catalog module

    Jetzt sieht man https:// aber das grüne Schloss nur für einen kurzen Augenblick, dann ist es wieder grau und ohne Schloss in der Adresszeile. Bei Anmeldung im Adminbereich ist die Anfangszeile grün mit Schloss. Cache und template_c sind geleert.
    Was fehlt jetzt noch?

  7. #7
    Administrator Avatar von KlausK
    Registriert seit
    29.09.2010
    Beiträge
    3.009
    Downloads
    267
    Uploads
    441

    AW: SSL Problem

    Nach der Anleitung für den XTC hast du jetzt den ganzen Shop via SSL eingebunden. Das ist grundsätzlich nicht verkehrt, funktioniert aber noch nicht mit jedem Shop auf jedem Server. Das musst du also noch etwas beobachten.
    Nach kurzer Durchsicht scheint es bei dir aber korrekt zu funktionieren. Allerdings hast du einige Objekte statisch verlinkt, z.B. mit http://gridisonline.de/geschenkideen/ Das führt natürlich zu Fehlern.
    Beispiele: Dein HOME-Link oben links, die Links im Slider, Kontaktlink im Footer, usw.
    Sämtliche Objekte sollten im Hauptverzeichnis deines Shops liegen. Dann kannst du auch relative Pfade verwenden wie /geschenkideen/ Dann gibt es auch keine Probleme mehr.

  8. #8
    Neuer Benutzer
    Registriert seit
    12.06.2014
    Ort
    Norderstedt
    Beiträge
    10
    Downloads
    5
    Uploads
    0

    AW: SSL Problem

    Hallo Klaus,

    ja zum Teil stimmt es jetzt nur bei manchen Kategorien ist das Schloss nicht grün.

    Was meinst du mit

    "Sämtliche Objekte sollten im Hauptverzeichnis deines Shops liegen. Dann kannst du auch relative Pfade verwenden wie /geschenkideen/ Dann gibt es auch keine Probleme mehr."

    wie kann ich das machen? Kannst du mir das vielleicht an einem Beispiel zeigen?

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •