Ergebnis 1 bis 8 von 8

Thema: SEO Artikel-URLS aktiviert/ Suche geht nicht mehr

Hybrid-Darstellung

  1. #1
    Benutzer
    Registriert seit
    09.02.2016
    Beiträge
    49
    Downloads
    44
    Uploads
    0

    SEO Artikel-URLS aktiviert/ Suche geht nicht mehr

    Guten Tag,

    hatte schon einmal das Problem beschrieben, allerdings kriege ich einfach das nicht hin.
    Und zwar folgendes: In dem Shop sind bei SEO-BOOST alle haken drin ausser "Suchmaschinenfreundliche URLs Pro für Artikeldetailseiten aktivieren" . Wenn ich diese aktiviere und "URL's reparieren" klicke, den kompletten Cache auf dem Server leere, funktioniert die Artikelsuche im Shop nicht mehr bzw er findet die Artikel nicht mehr. Es kommt immer die Meldung: die Suche ergibt keine Treffer. Wenn ich die Artikel manuell anklicke über das Menü, dann kommt dies ebenfalls, das heisst er findet die Artikel unter den optimierten URL's einfach nicht.

    Die .htaccess sieht folgendermaßen aus:

    ## Gambio SEO Boost
    ## www.gambio.de



    Header add Access-Control-Allow-Origin "*"
    Header add Access-Control-Allow-Headers "origin, x-requested-with, content-type"
    Header add Access-Control-Allow-Methods "PUT, GET, POST, DELETE, OPTIONS"

    <ifModule mod_headers.c>
    Header set X-Content-Type-Options: nosniff
    </ifModule>

    RewriteEngine on
    RewriteBase /

    RewriteCond %{REQUEST_FILENAME} ^(.*)\.(php|css|js|gif|jpg|jpeg|png)$ [NC]
    RewriteRule ^(.+) - [L]

    RewriteCond %{REQUEST_URI} (.*)?/admin/(.*)
    RewriteRule ^(.+) - [L]

    RewriteCond %{REQUEST_URI} (.*)?/images/(.*)
    RewriteRule ^(.+) - [L]

    RewriteCond %{REQUEST_URI} (.*)?/templates/(.*)
    RewriteRule ^(.+) - [L]


    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^(.+) - [L]

    RewriteCond %{REQUEST_FILENAME} -f
    RewriteRule ^(.+) - [L]

    RewriteCond %{REQUEST_FILENAME} -l
    RewriteRule ^(.+) - [L]

    RewriteCond %{HTTP_HOST} ^www\.bhm-maschinen\.de$
    RewriteRule ^(.*)$ http://bhm-maschinen.de/$1 [L,R=301]


    ##boosted CONTENT
    RewriteRule (^[a-z]{2})/(.*/)?info/([A-Za-z0-9_-]+)\.html.* shop_content.php?language=$1&gm_boosted_content=$3 &%{QUERY_STRING} [PT,L]
    RewriteRule (.*/)?info/([A-Za-z0-9_-]+)\.html.* shop_content.php?gm_boosted_content=$2&%{QUERY_STR ING} [PT,L]

    ##boosted PRODUCTS
    RewriteRule (^[a-z]{2})/(.*/)?([A-Za-z0-9_-]+)\.html product_info.php?language=$1&gm_boosted_product=$3 &%{QUERY_STRING} [PT,L]
    RewriteRule (.*/)?([A-Za-z0-9_-]+)\.html product_info.php?gm_boosted_product=$2&%{QUERY_STR ING} [PT,L]

    ##boosted CATEGORIES
    RewriteRule (^[a-z]{2})/(.*/)?([A-Za-z0-9_-]+)/?.* index.php?language=$1&gm_boosted_category=$3&%{QUE RY_STRING} [L]
    RewriteRule (.*/)?([A-Za-z0-9_-]+)/?.* index.php?gm_boosted_category=$2&%{QUERY_STRING} [L]



    Habe schon ausprobiert alle URLS zu deaktivieren, Seo boost aus in die htaccess zu machen und wieder zurück, aber er findet einfach die artikel urls nicht.

    Falls das alles nicht hilft, gibt es die Möglichkeit das in der Datenbank irgendwelche altlasten nicht rausgelöscht werden und er deshalb da Probleme hat?

    Wäre super wenn jemand eine Idee hätte, ich weiß nämlich nicht mehr wirklich weiter.

  2. #2
    Administrator Avatar von KlausK
    Registriert seit
    29.09.2010
    Beiträge
    2.664
    Downloads
    226
    Uploads
    325

    AW: SEO Artikel-URLS aktiviert/ Suche geht nicht mehr

    SEO-Boost funktioniert nicht mit SSL-Proxys. Guckst du 40282 Wenn SSL, dann nach Möglichkeit ein richtiges Zertifikat!
    Da ich deinen Shop nicht kenne, weiß ich nicht ob du einen SSL-Proxy verwendest.

    Warum sind in deiner .htaccess CORS-Header eingefügt? Liegt dein Shop, oder Teile davon, in der Microsoft Azure-Cloud?
    Bin mir nicht ganz sicher ob der Shop überhaupt als Cloud-Anwendung 100%ig läuft!?

  3. #3
    Benutzer
    Registriert seit
    09.02.2016
    Beiträge
    49
    Downloads
    44
    Uploads
    0

    AW: SEO Artikel-URLS aktiviert/ Suche geht nicht mehr

    Hallo,

    vielen Dank für deine Antwort! Der Shop liegt nicht in einer Azure Cloud, der CORS-Header war noch von einer anderen htaccess datei übernommen .. hab ich rausgemacht, allerdings löst das das Problem nicht.
    Der Shop ist normal auf einem Hostingpaket bei Domainfactory und hat ein SSL-Zertifikat. Von den 4 Seo-Boost Punkten geht auch lediglcih der mit den Artikeln nicht, alle anderen 3 Seo Boost "Suchmaschinenfreundliche URLs Pro für Kategorieseiten aktivieren" ,"Suchmaschinenfreundliche URLs Pro für Content-Manager-Seiten aktivieren", "Ländercode in URLs integrieren" funktionieren auch. Deshalb versteh ich auch das Problem nicht wirklich, warum nach Aktivieren der Artikel-URL's die Artikel nicht mehr aufrufbar sind.

    Grüße scleo

  4. #4
    Benutzer
    Registriert seit
    09.02.2016
    Beiträge
    49
    Downloads
    44
    Uploads
    0

    AW: SEO Artikel-URLS aktiviert/ Suche geht nicht mehr

    Hab jetzt herausgefunden, das wenn ich die Artikel die nicht mehr angezeigt werden im Backend auf Bearbeiten anklicke und speichere, es dann geht.

    Leider muss ich da 5000 Artikel anklicken ... hat das jemand schonmal gehabt?

    Grüße

  5. #5
    Administrator Avatar von KlausK
    Registriert seit
    29.09.2010
    Beiträge
    2.664
    Downloads
    226
    Uploads
    325

    AW: SEO Artikel-URLS aktiviert/ Suche geht nicht mehr

    Dann muss die Ursache ja in der Datenbank liegen. Fehlerhafte Einträge, zum Beispiel.
    Nutzt du noch andere Software, die auf die DB zugreift?
    Kannst du denn in der DB Unterschiede zwischen vorher und nachher feststellen?

  6. #6
    Benutzer
    Registriert seit
    09.02.2016
    Beiträge
    49
    Downloads
    44
    Uploads
    0

    AW: SEO Artikel-URLS aktiviert/ Suche geht nicht mehr

    Problem ist gelöst, lag in der Datenbank an der gm_url_keywords, da waren Fehler drin, danke für die Hilfe!

Ähnliche Themen

  1. Antworten: 4
    Letzter Beitrag: 29.09.2016, 05:55
  2. Paypal Checkout geht nicht mehr
    Von charly56 im Forum Gambio GX Adminbereich
    Antworten: 3
    Letzter Beitrag: 08.03.2016, 14:08
  3. Hilfe shop geht nicht mehr seid heute Morgen
    Von schnapi im Forum Shopsoftware
    Antworten: 4
    Letzter Beitrag: 06.05.2015, 22:29
  4. Hilfe seit Heute geht mein SHOP nicht mehr !!!
    Von 52056 im Forum Shopsoftware
    Antworten: 2
    Letzter Beitrag: 06.05.2015, 15:46
  5. Login, Suche und Untermenüs funktionieren nicht mehr
    Von jewel-world im Forum Gambio GX Adminbereich
    Antworten: 10
    Letzter Beitrag: 30.03.2015, 09:03

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •