Ab sofort wird PHP in Version 5 nicht mehr weiterentwickelt.
PHP v5.6 erhlt noch bis zum 31.12.2018 Sicherheitsupdates, dann ist auch damit Schluss.
Alle anderen PHP 5 Versionen erhalten bereits jetzt schon keine Sicherheitsupdates mehr.

Das heit also, wer auf Nummer sicher gehen will, sollte mglichst zeitnah seinen alten Gambioshop auf mindestens Version 3.1.x bringen und anschlieend seinen Webspace auf PHP 5.6.x upgraden (nicht umgekehrt!).
Besser wre es noch, die Gambio Shopsoftware gleich auf den allerneuesten Stand GX v3.3.1.2 zu bringen und dann auf PHP 7.0.x zu aktualisieren. PHP 7.1.x ist erstmal noch mit Vorsicht zu genieen.

Beachtet dabei unbedingt, dass auch fremde Module und Komponenten, die ihr um euren Shop herum verbaut habt, ebenfalls entsprechend aktualsiert werden mssen!

Nhere Infos: Heise Developer