Ergebnis 1 bis 2 von 2

Thema: Internal Server Error 500

  1. #1
    Neuer Benutzer
    Registriert seit
    20.03.2015
    Beiträge
    3
    Downloads
    111
    Uploads
    0

    Internal Server Error 500

    Hallo zusammen,

    ich würde mich freuen, wenn man mir jemand zu folgendem Problem eine Hilfestellung geben könnte:

    Ausgangsdaten:
    Shopversion: 3.11.3.0
    Hoster: Strato

    Template: Honeygrid, für diese Version angepasst
    1. Domain: www.abl-teile.de (v3.11.3.0)
    2. Domain: www.nanakewe.de (3.11.3.0 - läuft ohne Probleme)

    Für beide Shops wird das Flat-SSL-Zertifikat genutzt.

    Der Shop abl-teile.de lief auch nach der Installation ohne Probleme. Ohne Änderungen an den Dateien/Datenbank lief der Shop bei Auswahl eines Produkts auf einmal auf Internal Error 500, nach Aktualisieren mit F5 wurde der Shop geladen.

    Da nichts am Shop geändert wurde, hatte ich zuerst Strato im Verdacht, dass diese irgendetwas geändert haben. Aber nach Rücksprache mit dem Supporter, ist dies wohl nicht so.

    Kurios ist, dass der 2. Shop ohne Probleme läuft, die beiden Shops sind von den Dateien her identisch.

    Was habe ich bisher versucht:
    - auf Standard-Template umschalten - kein Erfolg
    - SSL deaktiviert - kein Erfolg

    Nach jedem Versuch die Caches /Cache und /Templates_C manuell gelöscht.

    Nach vielen Versuchen habe ich die Domain von abl-teile.de auf abl-teile.com gelegt und der Shop läuft wie gewollt. Stelle ich dagegen wieder auf abl-teile.de um, bekomme ich wieder den Server-Error.

    01.04.2019 09:24:58 abl-teile.de [client 85.214.29.0] FastCGI: "/.../index.php" aborted: no response after 123 sec (idle timeout 120 sec)
    01.04.2019 09:25:02 abl-teile.de [client 85.214.29.0] FastCGI: "/.../index.php" aborted: no response after 123 sec (idle timeout 120 sec)
    01.04.2019 09:25:02 abl-teile.de [client 85.214.29.0] FastCGI: "/.../index.php" aborted: no response after 123 sec (idle timeout 120 sec)
    01.04.2019 09:25:02 abl-teile.de [client 85.214.29.0] FastCGI: "/.../index.php" aborted: no response after 123 sec (idle timeout 120 sec)
    01.04.2019 09:25:03 abl-teile.de [client 85.214.29.0] FastCGI: "/.../request_port.php" aborted: no response after 123 sec (idle timeout 120 sec)
    01.04.2019 09:25:25 abl-teile.de [client 85.214.29.0] FastCGI: "/.../product_info.php" aborted: no response after 123 sec (idle timeout 120 sec)
    01.04.2019 09:26:01 abl-teile.de [client 85.214.29.0] FastCGI: "/.../index.php" aborted: no response after 123 sec (idle timeout 120 sec)
    01.04.2019 09:27:28 abl-teile.de [client 85.214.29.0] FastCGI: "/.../index.php" aborted: incomplete headers (0 bytes) received from server after 122 sec

    Einziger Eintrag im Gambio-Log:
    USER NOTICE(1024): "menubox not found in settings-array: paypalinstallments"

    Dies könnte aber an der zurvor installierten alten Paypal-Version liegen. Es wird PaypalPlus genutzt.

    Hat jemand eine Idee, worauf dieses Verhalten zurückzuführen ist? Vielleicht irgendwelche DNS-Einstellungen (IP4/6), wo die Domain registriert ist? Die Strato-Domain-Einstellungen sind bei allen Domains die selben.

    Komme hier einfach nicht weiter.

    Beste Grüße
    Steffen

  2. #2
    Neuer Benutzer
    Registriert seit
    20.03.2015
    Beiträge
    3
    Downloads
    111
    Uploads
    0

    AW: Internal Server Error 500

    Hallo zusammen,

    habe es jetzt selbst rausgefunden. Die Daten werden in den Shop per externer Software eingespielt (CSV->WaWi->Gambio). Diese Daten enthielten (schon vom Lieferanten aus) ISO-8859-1-Zeichen, zB. 0x90 oder 0x96. Beim normalen Artikelnamen hat dies nichts weiter ausgemacht, aber bei den Namen der Artikelbilder. Hier hat der Server versucht, das Artikelbild mit ISO-8859-1 Zeichen zu lesen und hat sich daran "verschluckt", was zum Internal Error 500 führte. Warum dies jedoch nur bei der .de-Domain ein Problem war und bei der.com-Domain nicht, weiß ich leider auch nicht.

Ähnliche Themen

  1. Internal Server Error 500
    Von SteffenJ im Forum Shopsoftware
    Antworten: 0
    Letzter Beitrag: 01.04.2019, 09:22
  2. Antworten: 4
    Letzter Beitrag: 10.03.2019, 22:51
  3. Server Umzug
    Von Tormentor im Forum Shopsoftware
    Antworten: 14
    Letzter Beitrag: 31.07.2017, 08:56
  4. Error: Unknown column 'pic.identifier_exists' in 'field list' (error 1054)
    Von clement-it-tk im Forum Gambio GX Adminbereich
    Antworten: 6
    Letzter Beitrag: 06.10.2014, 21:47
  5. Internal Server Error bei Produkt-Download
    Von nadine0503 im Forum Gambio GX Off Topic
    Antworten: 22
    Letzter Beitrag: 08.01.2014, 17:45

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •