Ergebnis 1 bis 5 von 5

Thema: Kann Shopsoftware nicht aktualisieren

  1. #1
    Neuer Benutzer
    Registriert seit
    31.01.2020
    Beiträge
    6
    Downloads
    2
    Uploads
    0

    Kann Shopsoftware nicht aktualisieren

    Hallo,

    wir benutzen die Gambiasoftware GX (zur Zeit noch 3.9.3.0). Mit den Updates hab ich ein wenig geschlampt...(lief ja alles ordentlich).
    Jetzt hab ich auf PHP 7.3 umgestellt und siehe da...der Warenkorb macht Probleme.

    Beim Versuch zunächst einmal das Master-Uptade auf 3.10. runter zu laden um es zu installieren, bekomme ich aber nur noch Fehlermeldungen und auch die Gambio Webseite ist nicht erreichbar.
    Hat jemand ne Idee was da los ist?

    Danke und Gruß
    RoHa

  2. #2
    Neuer Benutzer
    Registriert seit
    31.01.2020
    Beiträge
    6
    Downloads
    2
    Uploads
    0

    AW: Kann Shopsoftware nicht aktualisieren

    Vielleicht hat ja auch direkt jemand eine Lösung für das Warenkorbproblem?

    Folgende Fehlermeldung wird ausgegeben:
    WARNING(2): "Use of undefined constant MODULE_ORDER_TOTAL_SHIPPING_DESTINATION - assumed 'MODULE_ORDER_TOTAL_SHIPPING_DESTINATION' (this will throw an Error in a future version of PHP)"

    Wenn ich wieder PHP 5.6 aktivieren funktioniert es auch wieder.

    Im Forum hatte ich bereits gefunden, dass dies an einem "Nichts" in einem Versandmodul liegen kann, dass PHP7 nicht mehr auswerten kann und dann dort "0" eingetragen sein muss.
    Ich hab aber auch bereits alle Versandmodule deinstalliert (wir versenden als Industrieanbieter eh ausschließlich per Spedition). Dies hat leider auch keinen Erfolg gezeigt.

    Für einen Tip wäre ich dankbar.

    Gruß
    RoHa

  3. #3
    Administrator Avatar von KlausK
    Registriert seit
    29.09.2010
    Beiträge
    3.016
    Downloads
    267
    Uploads
    454

    AW: Kann Shopsoftware nicht aktualisieren

    Der Tipp ist ganz einfach:
    Unter PHP 5.6.x auf Gambio GX v3.14.2.0 aktualisieren
    Dann auf PHP 7.3.x umstellen
    Dann auf Gambio GX v3.15.4.0 aktualisieren

    Und immer schön die Caches zwischendurch leeren.

    Siehe Tabelle Unterstützte PHP-Versionen

  4. #4
    Neuer Benutzer
    Registriert seit
    31.01.2020
    Beiträge
    6
    Downloads
    2
    Uploads
    0

    AW: Kann Shopsoftware nicht aktualisieren

    Hallo,

    nach diversen Updates und Umstellung auf PHP 7.3 haben ich nun ein Problem mit dem Warenkorb.

    In einem vorherigen Beitrag hatte ich bereits nach den entsprechenden Update gefragt die nun auf der Supportseite auch wieder zum runterladen bereit standen.
    Ich habe also ganz fleißig ein Update nach dem anderen eingespielt und dabei zum einem peinlich genau auf die jeweilige Kompatibilität geachtet und auch immer ordentlich die Caches geleert.
    So bin ich also nun aktuell bei der Version 3.15.4.1 angelangt. Die PHP Umstellung hatte ich (wie von KlausK empfohlen ... Danke nochmal) nach dem Update auf 3.14.2.0 gemacht.

    Leider habe ich nun immer noch das Problem mit dem Warenkorb. Wenn ich einen Artikel (oder auich mehrere) ausgewählt habe und dann auf Warenkorb klicken kommen die folgenden Meldungen (und sonst nix mehr..nur eine blanke Seite mit den Meldungen):

    WARNING(2): "Use of undefined constant MODULE_ORDER_TOTAL_SHIPPING_DESTINATION - assumed 'MODULE_ORDER_TOTAL_SHIPPING_DESTINATION' (this will throw an Error in a future version of PHP)"

    Fatal error: Allowed memory size of 104857600 bytes exhausted (tried to allocate 3124280 bytes) in /domain/system/core/logging/LogEvent.inc.php on line 1039

    Als Versandmodul habe ich nur noch Selbstabholer aktiviert und auch darauf geachtet, dass in den Versandoptionen keine leeren Felder mehr vorhanden sind.
    Daher die Frage ... SHIPPING_DESTINATION ?!?

    Auch habe ich nirgends etwas gefunden wo man einen Speicherplatz deffinieren kann, also welcher "Allowed memory"?!?

    Testweise zurück zu PHP 5 kann ich auch nicht mehr, da dann anstelle des Anmeldefensters nur nochg die folgende Meldung kommt:

    Parse error: syntax error, unexpected '?' in /domain/index.php on line 57

    Wenn jemand einen Tip für mich hat...immer gerne.
    Danke
    Rolf

  5. #5
    Administrator Avatar von KlausK
    Registriert seit
    29.09.2010
    Beiträge
    3.016
    Downloads
    267
    Uploads
    454

    AW: Kann Shopsoftware nicht aktualisieren

    Je nach Hostingpaket und Anbieter kannst du die "memory_limit" auf unterschiedlichen Wegen oder sogar gar nicht einstellen. Im Zweifel direkt an den Anbieter wenden.
    In vielen Fällen kannst die das in der Managing-Konsole deines Anbieters einstellen. Bei Plesk wäre das im Bereich PHP-Einstellungen.
    Bei manchen Anbietern geht das nur direkt in der php.ini. Da kommt man selbst meist aber nicht dran.
    Bei Manchen Anbietern lässt sich das auch über die .htaccess einstellen.
    Wie gesagt, im Zweifel deinen Anbieter fragen.

    Die "memory_limit" sollte mindestens auf 128MB stehen.

    Du musst übrigens zwischendurch auch deinen Browsercache leeren. Siehe auch Wenn nichts mehr geht: Caches komplett leeren

Ähnliche Themen

  1. Kann das Masterupdate nicht downloaden
    Von Schippi im Forum ServicePacks
    Antworten: 2
    Letzter Beitrag: 10.05.2019, 16:56
  2. Kann CSV-Export Profil nicht speichern
    Von scleo im Forum Gambio GX Adminbereich
    Antworten: 2
    Letzter Beitrag: 20.10.2017, 16:55
  3. Artikelbestände via APP aktualisieren
    Von pherchristoph im Forum Gambio GX Module
    Antworten: 2
    Letzter Beitrag: 30.09.2016, 21:20
  4. Content-Manager kann Seite nicht aktualisieren/speichern
    Von scleo im Forum Gambio GX Adminbereich
    Antworten: 3
    Letzter Beitrag: 04.08.2016, 15:12
  5. Bellendorf kann es nicht lassen! Fall 1
    Von HarryBoo im Forum Die Akte Volker B.
    Antworten: 0
    Letzter Beitrag: 04.12.2014, 12:15

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •