Seite 2 von 3 ErsteErste 123 LetzteLetzte
Ergebnis 11 bis 20 von 29

Thema: Fehlermeldung bei Update auf SP 4.1.1.0 - Masterupdate 4.0.0.1 vorher installiert

  1. #11
    Benutzer
    Registriert seit
    08.04.2014
    Ort
    Lahnstein
    Beiträge
    33
    Downloads
    73
    Uploads
    0

    AW: Fehlermeldung bei Update auf SP 4.1.1.0 - Masterupdate 4.0.0.1 vorher installiert

    Hi,

    habe das Update gestern aufgespielt Fehler von oben nicht behoben. Nun kommen sogar im Adminbereich Fehlermeldungen, wenn ich z.B. Bestellungen aufrufe, dass die Seite nicht erreicht werden kann.

    Fehlercode 500.

    Folgeende Serverinfo habe ich:

    {
    "gambio":"v4.1.1.2",
    "phpversion":"7.4.6",
    "mysqlversion":"5.6.42-log",

    Wäre super wenn ihr mir helfen könntet.

    VG

  2. #12
    Benutzer
    Registriert seit
    08.04.2014
    Ort
    Lahnstein
    Beiträge
    33
    Downloads
    73
    Uploads
    0

    AW: Fehlermeldung bei Update auf SP 4.1.1.0 - Masterupdate 4.0.0.1 vorher installiert

    Hi,

    habe das Update durchgeführt und trotzdem bleibt der Fehler.

    Leider ist es nach dem Update sogar noch schlimmer. Wenn ich im ADMIN-Bereich auf Bestellungen klicke, dann kommt der Fehler 500, derzeit nicht erreichbar. Kann mir aber
    hier nicht erklären warum.

    Die Serverdaten die ich aus dem Shop herauslese sind wie folgt:

    gambio":"v4.1.1.2",
    "phpversion":"7.4.6",
    "mysqlversion":"5.6.42-log",

    Hatte nicht gesehen, dass der Post bereits auf der 2. Seite war.

    VG

  3. #13
    Administrator Avatar von KlausK
    Registriert seit
    29.09.2010
    Beiträge
    3.124
    Downloads
    294
    Uploads
    476

    AW: Fehlermeldung bei Update auf SP 4.1.1.0 - Masterupdate 4.0.0.1 vorher installiert

    Bitte teste mal die PHP Version 7.3.x und anschließend 7.2.x

    Bzgl. Admin-Bereich bitte dieser Anleitung folgen: http://ecomservice.de/threads/2054-K...n-Bereich-rein

  4. #14
    Benutzer
    Registriert seit
    08.04.2014
    Ort
    Lahnstein
    Beiträge
    33
    Downloads
    73
    Uploads
    0

    AW: Fehlermeldung bei Update auf SP 4.1.1.0 - Masterupdate 4.0.0.1 vorher installiert

    Hi Klaus,

    habe es probiert wie du geschrieben hast. Leider geht es nicht. Es ist auch egal welche PHP Version ich nehme.

    Hast du noch eine Idee? Wie gesagt ist nur der Reiter Bestellung der den Fehler 500 bringt.

    VG

  5. #15
    Administrator Avatar von KlausK
    Registriert seit
    29.09.2010
    Beiträge
    3.124
    Downloads
    294
    Uploads
    476

    AW: Fehlermeldung bei Update auf SP 4.1.1.0 - Masterupdate 4.0.0.1 vorher installiert

    Welche PHP-Version hattest du denn bei der letzten Shopversion 4.0.0.1?
    Oder anders: Mit welcher PHP-Version hast du das Update von 4.0.0.1 auf v4.1.1.0 gemacht?

  6. #16
    Benutzer
    Registriert seit
    08.04.2014
    Ort
    Lahnstein
    Beiträge
    33
    Downloads
    73
    Uploads
    0

    AW: Fehlermeldung bei Update auf SP 4.1.1.0 - Masterupdate 4.0.0.1 vorher installiert

    Hi,

    da ich nachgelesen habe, dass mindestens eine PHP 7.2 benötigt wird und mir bei Strato bereits 7.4 anbietet, habe ich auch
    die 7.4 direkt angewendet, bevor ich das Masterupdate 4.0.0.1 installiert habe. Derzeit habe ich es wieder auf die 7.2 wie die Mindestanforderung
    ist, abgeändert.

    Danke für die Hilfe vorab.

  7. #17
    Benutzer
    Registriert seit
    08.04.2014
    Ort
    Lahnstein
    Beiträge
    33
    Downloads
    73
    Uploads
    0

    AW: Fehlermeldung bei Update auf SP 4.1.1.0 - Masterupdate 4.0.0.1 vorher installiert

    Hallo,

    kleines extra:

    Habe mal versucht eine Bestellung zu machen und dann kommt der ganze Fehlertext:

    " Before creating a order context, the order totals must be written to the session.
    #0 /mnt/web421/a2/23/51885023/htdocs/SHOPNEW4/admin/includes/TeleCashCw/classes/TeleCashCw/PaymentMethod.php(545): TeleCashCw_PaymentMethod->getOrderContext() #1 /mnt/web421/a2/23/51885023/htdocs/SHOPNEW4/admin/includes/cw-libs/Customweb/Licensing/TeleCashCw/Key.php(21) : eval()'d code(1) : eval()'d code(1) : eval()'d code(1) : eval()'d code(23) : eval()'d code(55) : eval()'d code(30): TeleCashCw_PaymentMethod->call_d9qdljett1gl7of5('getOrderContext', 'ns') #2 /mnt/web421/a2/23/51885023/htdocs/SHOPNEW4/admin/includes/cw-libs/Customweb/Licensing/TeleCashCw/Key.php(21) : eval()'d code(1) : eval()'d code(1) : eval()'d code(1) : eval()'d code(23) : eval()'d code(55): eval() #3 /mnt/web421/a2/23/51885023/htdocs/SHOPNEW4/admin/includes/TeleCashCw/classes/TeleCashCw/PaymentMethod.php(533): Customweb_Licensing_TeleCashCw_License::run('9giie 9n3qitovtm...', Object(telecashcw_creditcard), NULL) #4 /mnt/web421/a2/23/51885023/htdocs/SHOPNEW4/includes/classes/payment.php(249): TeleCashCw_PaymentMethod->selection() #5 /mnt/web421/a2/23/51885023/htdocs/SHOPNEW4/GXModules/Gambio/Hub/Shop/Overloads/payment/GambioHubPayment.inc.php(62): payment_ORIGIN->selection() #6 /mnt/web421/a2/23/51885023/htdocs/SHOPNEW4/GXMainComponents/View/ThemeContentViews/checkout/CheckoutPaymentModulesThemeContentView.inc.php(65) : GambioHubPayment->selection() #7 /mnt/web421/a2/23/51885023/htdocs/SHOPNEW4/GXModules/Gambio/Hub/Shop/Overloads/CheckoutPaymentModulesThemeContentView/GambioHubCheckoutPaymentModulesThemeContentView.in c.php(44): CheckoutPaymentModulesThemeContentView->prepare_data() #8 /mnt/web421/a2/23/51885023/htdocs/SHOPNEW4/GXMainComponents/View/ThemeContentViews/core/ThemeContentView.inc.php(147): GambioHubCheckoutPaymentModulesThemeContentView->prepare_data() #9 /mnt/web421/a2/23/51885023/htdocs/SHOPNEW4/GXModules/Gambio/Hub/Shop/Overloads/CheckoutPaymentModulesThemeContentView/GambioHubCheckoutPaymentModulesThemeContentView.in c.php(61): ThemeContentView->get_html() #10 /mnt/web421/a2/23/51885023/htdocs/SHOPNEW4/GXMainComponents/View/ThemeContentViews/checkout/CheckoutPaymentThemeContentView.inc.php(427): GambioHubCheckoutPaymentModulesThemeContentView->get_html() #11 /mnt/web421/a2/23/51885023/htdocs/SHOPNEW4/GXMainComponents/View/ThemeContentViews/checkout/CheckoutPaymentThemeContentView.inc.php(92): CheckoutPaymentThemeContentView->_assignPaymentBlock() #12 /mnt/web421/a2/23/51885023/htdocs/SHOPNEW4/GXModules/Gambio/GoogleECommerce/Shop/Overloads/CheckoutPaymentThemeContentView/GoogleAnalyticsThemeCheckoutPayment.inc.php(21): CheckoutPaymentThemeContentView->prepare_data() #13 /mnt/web421/a2/23/51885023/htdocs/SHOPNEW4/GXMainComponents/View/ThemeContentViews/core/ThemeContentView.inc.php(147): GoogleAnalyticsThemeCheckoutPayment->prepare_data() #14 /mnt/web421/a2/23/51885023/htdocs/SHOPNEW4/system/classes/checkout/CheckoutPaymentContentControl.inc.php(210): ThemeContentView->get_html() #15 /mnt/web421/a2/23/51885023/htdocs/SHOPNEW4/GXModules/Gambio/Hub/Shop/Overloads/CheckoutPaymentContentControl/GambioHubStartSession.inc.php(30): CheckoutPaymentContentControl->proceed() #16 /mnt/web421/a2/23/51885023/htdocs/SHOPNEW4/checkout_payment.php(57): GambioHubStartSession->proceed() #17 {main}"


    Also hier scheint mehr nicht zu gehen als unter ADMIN Bestellungen. Verstehe es nur nicht.

    VG

  8. #18
    Administrator Avatar von KlausK
    Registriert seit
    29.09.2010
    Beiträge
    3.124
    Downloads
    294
    Uploads
    476

    AW: Fehlermeldung bei Update auf SP 4.1.1.0 - Masterupdate 4.0.0.1 vorher installiert

    Die Shopversion 4.0.x.x ist nur für die PHP-Versionen 7.1.x bis 7.3.x freigegeben!
    Der neue Shop ab 4.1.x ist nur für die PHP-Versionen 7.2.x bis 7.4.x freigegeben!
    Daher kommen vermutlich auch deine Fehler. Die Probleme könnten sich auch schon mit dem Masterupdate 4.0.0.1 eingeschlichen haben.
    Wenn der Shop unter PHP 7.4 funktionierte, dann nur weil keine Funktionen aufgerufen wurden, die mit PHP 7.4 deaktiviert oder geändert wurden.
    Dazu kommt, dass PHP 7.4 mit der Veröffentlichung am 28.11.2019 noch relativ frisch ist. Auch wenn Gambio sagt "GX 4.1.1.2 geeignet bis PHP 7.4" könnten damit häufiger Fehler auftreten als unter PHP 7.3
    Wer auf Nummer Sicher gehen will, bleibt immer eine Minor-Version drunter. In diesem Fall wäre also PHP 7.3.18 die bessere Wahl.

    Konkret heißt das für dich, auf PHP 7.3.18 umstellen, dann Shop zurücksetzen auf die Version vor dem Masterupdate 4.0.0.1, dann das Masterupdate 4.0.0.1, dann das ServicePack 4.1.1.2
    Anschließend trotzdem nochmal die SessionService.php tauschen. Da gab es ein Fehler im letzten Update.
    Dauerhaft auf PHP 7.4 würde ich erst umschalten, wenn der Shop für PHP 7.5 respektive PHP 8 freigegeben ist.

  9. #19
    Benutzer
    Registriert seit
    08.04.2014
    Ort
    Lahnstein
    Beiträge
    33
    Downloads
    73
    Uploads
    0

    AW: Fehlermeldung bei Update auf SP 4.1.1.0 - Masterupdate 4.0.0.1 vorher installiert

    Hi Klaus,

    also soll ich im Klartext das Backup vom Verzeichnis /admin/backups/ herunterladen und dann per FTP auf den Shop aufspielen. Wäre dann das Backup bevor ich das Masterupdate aufgespielt habe.
    Danach noch irgendwelche Dateien löschen? Bin mir nicht sicher.

    An der Datenbank sowie dem Bilder Backup muss ich ja eigentlich nichts machen oder habe ich da was falsch verstanden.

    VG

    Derzeit ist PHP 7.2.31 laut Server Info aktiviert. Soll ich trotzdem auf die 7.3 gehen?

  10. #20
    Administrator Avatar von KlausK
    Registriert seit
    29.09.2010
    Beiträge
    3.124
    Downloads
    294
    Uploads
    476

    AW: Fehlermeldung bei Update auf SP 4.1.1.0 - Masterupdate 4.0.0.1 vorher installiert

    Im Handbuch steht es genau beschrieben: https://developers.gambio.de/manual....ateien_sichern

    Datenbank und Shopdateien müssen wieder hergestellt werden. Beides muss natürlich aus der selben Version stammen.

    Du kannst auch bei PHP 7.2.31 bleiben. Wenn du komplett fertig bist, dann kannst auf 7.3 gehen

    Du solltest aber erstmal folgendes probieren:
    PHP 7.2.31 hast du ja bereits aktiv
    Lade noch mal das aktuelle SP 4.1.1.2 hoch und starte den Updater
    Gehe auf "Versionsauswahl erzwingen" und wähle als deine "aktuelle Version" die Version 3.15.4.2 aus
    Danach sollte er alle Updates ab 4.0.0.0 bis 4.1.1.2 durchführen

    Wäre schön wenn das funktioniert
    Hatte es gerade getestet. Im Testshop habe ich damit nichts kaputt gemacht!

Ähnliche Themen

  1. Fehlermeldung nach Masterupdate von 3.7.3.0 auf 3.8.0.0
    Von rf-musik im Forum Gambio GX Adminbereich
    Antworten: 3
    Letzter Beitrag: 09.02.2018, 14:41
  2. Antworten: 2
    Letzter Beitrag: 03.04.2017, 04:47
  3. Fehlermeldung nach Update auf V 2.4
    Von Evolutionstore.de im Forum Shopsoftware
    Antworten: 8
    Letzter Beitrag: 28.10.2015, 18:29
  4. Fehlermeldung bei Masterupdate von 2.0.17 auf 2.1.0.7
    Von Herr-Mann im Forum Shopsoftware
    Antworten: 14
    Letzter Beitrag: 20.09.2015, 04:41
  5. Magnalister Modul installiert
    Von v-sand im Forum Gambio GX Adminbereich
    Antworten: 2
    Letzter Beitrag: 13.07.2014, 13:48

Stichworte

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •